cakephp1-2-xでのstrict-standards

PHP5.4以上の環境でCakePHP1.2.xを動かそうとしたところ、画面が真っ白。
app/config/core.phpのdebugフラグを1にしてみたところ、
Strict Standardsというエラーがすごい勢いで表示されました X<

どうやら、PHP5.4以降は古い書き方に対して
エラーとして新しい書き方を提案するようになったらしいです。
(エラー出力レベル E_ALLにE_STRICTが含まれるようになったとのこと)

エラーの非表示

app/Config/core.php

上記コードを下記のように書き換えると
正しく動作するようになるかと思います XD

ただ、このエラーはCakePHP1.3で修正されているようなので、
バージョンアップできるのであれば、してしまった方が良いかと思われます 😀

参考