brewでインストールしたapacheが起動しない

はじめに

だいぶアップデートを怠っていたので、
先日brewでupdateとupgradeを叩いたんです。
そしたらapacheが起動しなくなりました :'(

解決策

httpd: Syntax error on line 173 of /usr/local/etc/apache2/2.4/httpd.conf: Cannot load /usr/local/opt/php55/libexec/apache2/libphp5.so into server: dlopen(/usr/local/opt/php55/libexec/apache2/libphp5.so, 10): image not found

apachectlで起動させようとすると、
上記エラーがでていたので、PHP5.5のモジュールが
読み込めていないということは察せたのですが…

今までは動いていたのに突然モジュールが消えるなんて…
アップデートが原因としか考えられない >:(

というわけで下記コマンドで
再インストールしてみたところ、無事解決。

brew reinstall php55 --with-httpd24
brew unlink php55

参考